残留セッションで起動した公開アプリケーションがすぐに切断されることがある
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Description
残留セッションが有効な時、最後のアプリケーションが終了するとセッションが残留し、切断タイマーのカウントが開始されます。カウントが開始されてから、ポリシーの「残留セッションの切断タイマー」に設定された時間が経過すると、セッションの切断処理が行われます。この時、アプリケーションを起動するとアプリケーションのウィンドウが表示されますが、すぐに切断されてしまうことがあります。
Resolution
セッションが切断された後、再度アプリケーションを起動しようとすれば、セッションに再接続することができます。
また、XenApp 6.5 HRP6 では切断時のセッションプリンター削除処理に時間が長くなってしまうことがあるため、この事象の発生する可能性が高くなります。XenApp 6.5 HRP7 では、切断時のセッションプリンター削除処理時間が長くならないように修正されたため、HRP6 よりも事象が発生する可能性が低くなります。
Problem Cause
残留セッションの状態管理、状態以降後の処理、および、アプリケーションの起動処理が同期していないことからこうした現象が発生してしまいます。現象を防ぐためには、これらの状況を一括して管理するための機構が必要となりますが、XenApp 6.5 の構造ではそのような機構に対応しておりません。そのため、現象が発生することは制限事項となります。
典型的な例として、セッションプリンターの削除中にアプリケーションが起動できてしまうことで現象が発生します。残留セッションの切断処理の一環としてセッションプリンターの削除が行われますが、セッションの状態は残留中となっているためアプリケーションが起動できてしまいます。既に切断処理として進行しているため、セッションプリンターの削除が完了するとアプリケーションが実行されていても、セッションが切断されてしまいます。セッションプリンターの削除に時間がかかってしまうと、現象が発生する可能性が高くなるのはこのためです。
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