StoreFront fails to detect Receiver installation with Internet Explorer

StoreFront fails to detect Receiver installation with Internet Explorer

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Article ID: CTX224639

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only. Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.


When navigating to a Receiver for Web site using Internet Explorer, a user will be asked to run a small add-on to verify Receiver is installed. After allowing the add-on to run, if Receiver is installed at the user's endpoint, then the user should not be asked install Receiver. However, if the add-on does not properly register in the browser, the user could be prompted to install Receiver each time they reach the site as seen in the following screenshot:

Storefront requesting user to install Receiver

Environment

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Resolution

Since you cannot completely remove the Citrix ICA Client plugin from Internet Explorer, un-registering and then re-registering the ActiveX Control object using the following commands in the provided order will allow the plugin to function as expected:

  1. Regsvr32 /u "C:\Program Files (x86)\Citrix\ICA Client\wfica.ocx"
  2. Regsvr32 "C:\Program Files (x86)\Citrix\ICA Client\wfica.ocx"

Make sure that all Internet Explorer windows have been closed and iexplore.exe is not a running process in Task Manager before running these commands.

Problem Cause

The ActiveX Control object "wfica.ocx" is installed with Receiver and becomes registered upon the user accepting the request from the Receiver for Web site (StoreFront). If it does not properly register in IE add-ons when StoreFront runs the check to see if Receiver was installed it will not be able to perform this check and because of it will prompt the user to install Receiver again.

Going to Tools > Manage Add-ons in Internet Explorer, you will find that the "Citrix ICA Client" may show incomplete information, such as missing vendor information, version, and/or file date information.

Viewing the Citrix ICA Client ActiveX Control in "Manage Add-ons" in Internet Explorer

Additional Information

Additional information regarding manual registration of ActiveX Controls can be found here:
https://support.microsoft.com/en-us/help/146219/how-to-register-an-activex-control-.ocx-manually