Citrix StoreFront 3.9 Unable to Refresh

Citrix StoreFront 3.9 Unable to Refresh

book

Article ID: CTX224386

calendar_today

Updated On:

Description

Upgrading StoreFront from 3.6 to 3.9 works fine and when we open the Citrix StoreFront gives an error message:"unable to refresh" with error "A PowerShell SDK execution error occurred with exception thrown at defaultDocument".

Resolution

Complete the following steps to resolve the issue:

  1. Run the PowerShell command on StoreFront Server.
  2. Get-STFWebReceiverService, it gives error with "A PowerShell SDK execution error occurred with exception thrown at defaultDocument" 
  3. Compare Web.Config file for StoreWeb with Working and Non-working. 
  4. There is a "<clear />" entry on web.config file for the defaultdocuments in the web.config file for the Receiver for Web site on non-working server.  
  5. -Once we remove the <clear /> from web.config, StoreFront console should work fine.

Problem Cause

There is a "<clear />" entry on web.config file for the defaultdocuments in the web.config file for the Receiver for Web Site.

Issue/Introduction

Upgrading StoreFront from 3.6 to 3.9 works fine and when we open the Citrix StoreFront gives an error message:"unable to refresh" with error "A PowerShell SDK execution error occurred with exception thrown at defaultDocument".