XenDesktop 7.x Unable to launch published desktop with Adaptive transport policy enabled

XenDesktop 7.x Unable to launch published desktop with Adaptive transport policy enabled

book

Article ID: CTX224373

calendar_today

Updated On:

Description

In high latency networks such as Vsat 128kbps link, launching of a published desktop or published application may fail with the error "Connection Interrupted" when Adaptive Transport Policy is enabled.

Connection Interrupted

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

The connection error happens due to network fragmentation with NetScaler Gateway versions 11.1.54.x or older.
Also, performance or connection issues could happen if the underlying network alters the MTU to any value below 1500.
Reducing the EDT MSS to a smaller value would resolve the problem. Default value for EDT MSS is 1500. You can modify the default EDT MSS value by editing the Default ICA file for the corresponding store on the Storefront server.

Please refer to the below article:

How to Configure MTU when using EDT across VPN solutions
https://support.citrix.com/article/CTX231821.


Problem Cause

VSat link fragmentation causing network failure.
 

Additional Information

How to change Max Segment Size in Netscaler