Secure Hub Error: Request Failed on iOS devices

Secure Hub Error: Request Failed on iOS devices

book

Article ID: CTX224337

calendar_today

Updated On:

Description

This article explains how to troubleshoot the error Request Failed on iOS devices when we have cert+LDAP policy on Netscaler Gateway

Below error in the iOS Secure Hub logs indicates that the issue is because two factors Authentication is disabled.
,<MDM>,ERROR
(2),"ZDMIFace::ZDMCertCredsToMem:CertError:Either Identity Reference is nil (YES) or
Certificate Data Array nil (YES)",Background,com.apple.main-thread,c07,Worx
Home,/jenkins/workspace/iCommon/Source/OpSec/
opsec.cert.m,-[OpSecCert ZDMCertCredsToMem],278

Below error indicates that the NetScaler Gateway is out of licenses.
,RECEIVER_UI,INFO (4),"UICoordinator
showErrorMessage (error) -> Error Domain=com.citrix.me@work
Code=0 "(null)" UserInfo={OriginalError=Error
Domain=com.citrix.Receiver.AuthManager Code=6
"CAMAuthManErrorCodeOutOfLicences"
UserInfo={com.citrix.Receiver.AuthManager.DiagnosticDescription=The gateway is out
of licences,
NSLocalizedDescription=CAMAuthManErrorCodeOutOfLicences},
Store=<Store: 0x161981bc0>}",Active,com.apple.main-thread,c07,Worx
 

Resolution

  1. To enable two factor authentication on the NetScaler, navigate to NetScaler -- >NetScaler Gateway --> Policies -->Authentication -->CERT --->Select Cert Policy ---> Edit ---> Edit Configure Authentication CERT Profile --> Turn Two Factor to ON --> OK --> OK.
  2.  Terminate few running sessions under the NetScaler ---> NetScaler Gateway ---> Select Active User sessions and terminate.
  3.  Procure NetScaler Gateway license from Citrix if required.

Problem Cause

  • Certificate + LDAP authentication on the NetScaler (two-factor) was disabled.
  • The NetScaler Gateway is out of licenses