Error message "The Google Play logon request used an invalid device ID"
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Article ID: CTX224032
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Updated On:
Description
While setting up Google Play Credentials, we will receive the below error message on XenMobile Admin Console

Environment
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Resolution
Google Play Store offers several “Device ID” Apps, which are able to lookup the Device ID on Android Devices. But not all the applications provide the correct Device ID.
The application Device ID by Evozi fetches the correct Device ID on the Android Device.
Provide the Google Service Framework (GSF) obtained from this application, to the XenMobile Google Play Credential Setup page and this will resolve the issue.
Note: Simultaneously, verify the "Sign in and Security" on Google account settings if the Device ID is blocked.
Problem Cause
It can cause because of the following reasons
Additional Information
Device ID - https://play.google.com/store/apps/details?id=com.evozi.deviceid&hl=en
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