udadmin -list -a shows incorrect license usage for XenMobile

udadmin -list -a shows incorrect license usage for XenMobile

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Article ID: CTX223771

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Updated On:

Description

After migrating from MDM 9 to XMS 10.X used license count exceeds the expected limit
If you verify the checked out licenses using udadmin tool in licensing server, you should see licenses checked out for Used ID's as well as usernames.
Steps:

  1.   Run the following command to change the directory to the licensing utility path:
    • cd /opt/citrix/licensing/LS
  2.   Run the udadmin to list checked out licenses.
  • udadmin -list –a    ( The output of the preceding command lists all features, versions, counts of licenses, and the users and devices for each feature. )

Resolution

Should delete the licenses associated to usernames using udadmin tool.
  • Run the following command using udadmin for deleting user :

udadmin -f <CXM_ENTU_UD/feature> -user <username> –delete (This command releases one user license)
udadmin -f XDT_ENT_UD -user u8.08 -delete

  • Run the following command for deleting device : 
udadmin -f <CXM_ENTU_UD/feature> -device <device> –delete (Releases one device from one feature.)
udadmin -f XDT_ENT_UD -device dn01.88 -delete
  • You can create a Batch file to delete all User License & Device License
    1. For User License
for /f "tokens=1,2" %i in ('udadmin -list ^| find /i "_ud"') do @udadmin -f %j -user %i -delete
  1. For Device License
for /f "tokens=1,2" %i in ('udadmin -list ^| find /i "_ud"') do @udadmin -f %j -device %i -delete
 

Problem Cause

From XM-10 onwards, we use userIDs not usernames for checking out licenses.
Licenses are still associated to usernames which were from MDM 9 .