Local App Access Client Hosted Applications are not enumerating on VDA

Local App Access Client Hosted Applications are not enumerating on VDA

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Article ID: CTX223622

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Updated On:

Description

Customer had been using LAA successfully for the past year. At one point LAA stopped working on many of the user’s machines and the LAA application were no longer seen on the Desktop nor could they be invoked via command line. There were still some machines that successfully used LAA but many others that have stopped working

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

We created the value on the VDA, and rebooted the machine, and LAA shortcuts are available again. Reproduced on two other machines as well

Problem Cause

Cicaiface.dll was not loading on the VDA due to the following value missing

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\Install
Value Name: Location
Type: REG_SZ
Value: C:\Program Files\Citrix\