VPP Apps Does Not Appear on XenMobile Console After Accidental Deletion of the app.

VPP Apps Does Not Appear on XenMobile Console After Accidental Deletion of the app.

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Article ID: CTX223495

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Updated On:

Description

Deleted VPP applications does not sync with XenMobile Server automatically.

Summary
VPP is an Apple Enterprise program to distribute corporate App license to device through MDM. Citrix XenMobile makes use of Apple's API to associate / disassociate license based which are distributed through specific XenMobile Server / Service. This includes synchronization of data with Apple servers. XenMobile Server / Service maintains the following details:
  •  Local copy of the Application.
  •  User / Device Licenses mapping.
  •  This also includes registration status for each user, invitation links and a hash of associated iTunes ID.
  •  Meta-data of application or book and its capabilities.
  •  Every single license and user is synchronized with Apple as a self-contained JSON object. This means that every object contains a full copy of the data it’s related to. 

To Maintain data integrity, XenMobile performs 2 syncs
1. VPP Baseline Sync

  •    Sync all VPP account related information to XMS.
  •    As it has to Sync All VPP related data - The time taken to complete is directly propotional to number of apps associated with Account.

2. VPP Delta Sync

  •    Sync only differential data from last synchronization.
  •    Delta sync is much quicker than the “Baseline sync”

XenMobile default configuration is to perform Baseline every 720 minutes or 12 hours.

XenMobile Server Database Table references:

  • Local copy of VPP resource in table "RESOURCES_BAGS"
  • Provisioning information in table "PROVISIONING"
  • License information in table "AVPP_LICENSE"

Resolution

Ensure Baseline sync is set to 720 minutes or 12 hours. Delete references of the deleted VPP app from the tables if they exist.

 
1. To check if  app exists in RESOURCES_BAG table
select * from RESOURCES_BAG where NAME like '%web%' (where 'web' is the deleted app name)
If null response is received run second query.
 
2. From PROVISIONING table.
select STORE_ID, PROVISIONING_ID from PROVISIONING where FULLAPPLNAME like '%web%' (where 'web' is the deleted app name)
Make a note of STORE_ID and PROVISIONING_ID for the deleted app.
 
3. From AVPP_LICENSE
select * from AVPP_LICENSE where ADAM_ID = ‘374211477’ (where '374211477' is the store_id from previous query)
 
After validating the above run the following query to delete those stale reference from the database:
 
delete from PROVISIONING where PROVISIONING_ID = '111'
delete from AVPP_LICENSE where ADAM_ID = '374211477'

+ After that - Deploy the application again and wait for 10 minutes to an hour for the application to appear on console.

Problem Cause

  • VPP Baseline Sync Interval value was greater
  • Stale reference of the Deleted VPP app under the XenMobile Database

Issue/Introduction

This article summarizes the steps to follow if the VPP app does not appear after deletion from XenMobile Console/ VPP application ( with new version) doesn't show up after allocating new licenses to the new version.

Additional Information

CTX223198 - How VPP synchronization works