Error: "Cannot add app " on Android When Trying to Add App from XenMobile App Store

Error: "Cannot add app " on Android When Trying to Add App from XenMobile App Store

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Article ID: CTX223298

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Updated On:

Description

The user gets "Cannot add app " on the Android device when trying to add an app from XenMobile App Store, and MDM_ERROR_USER_DEPROVISIONED gets logged in Debug logs. Other already installed apps work normally. Device has not been purposefully removed, and the device looks normal in XenMobile console.

Resolution

  1. Re-enrollĀ the devices affected.
  2. FillĀ in the Global Catalog Root Context in the LDAP connector from XenMobile to bypass de-provisioning and preventing the issue from happening again.

Problem Cause

A possible cause is a username is not found when looking up with SamAccountName and LDAP is configured with UPN, that particular user is assumed terminated and removed from all user tables and his device marked as deprovisioned - reprovisioning a device.

This behavior is by design.