Customer is unable to access to the Cloud Hosted StoreFront web site

Customer is unable to access to the Cloud Hosted StoreFront web site

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Article ID: CTX223020

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Updated On:

Description

Customer is unable to access to the cloud hosted StoreFront web site (https:customerxxx.xendesktop.net) from their on-premise infrastructure.
 
While the issue occurred, the customer's cloud hosted StoreFront web site could be accessed with no problem from other external locations.
 
Therefore, the issue was ONLY occurring when users try to access the cloud hosted StoreFront from the customer's on-premise infrastructure.

Resolution

Configuring the proxy server settings to allow traffic to https://*.xendesktop.net resolved the problem.
 

Problem Cause

Further trouble shooting found that in the customer's on-premise infrastructure, any HTTP(s) requests would be filtered by a proxy server, which was pre-defined by the customer's network administrator.
 
After reviewing the proxy server setting, HTTP(s) traffic to https://*.xendesktop.net was found blocked.

Additional Information

Additionally for XenApp and XenDesktop Service to function properly, the following URLs must be contactable in order to operate within environments containing an internet proxy server or firewall restrictions.
 
                https://*.citrixworkspacesapi.net
                https://*.cloud.com
                https://cwsproduction.blob.core.windows.net/downloads
                https://*.xendesktop.net
                https://*.nssvc.net
 
Further information can be found below:
 
Internet Connectivity Requirements
http://docs.citrix.com/en-us/citrix-cloud/overview/requirements/internet-connectivity-requirements.html