Error: "The System is Currently Unavailable .... Contact Your Administrator" While Logging into Director

Error: "The System is Currently Unavailable .... Contact Your Administrator" While Logging into Director

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Article ID: CTX223000

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Updated On:

Description

Error: "The System is Currently Unavailable. Please Try Again Later or Contact Your Administrator" 

You may experience an issue login in to Director 7.x.

Director error

Resolution

Complete the following steps

  1. Open IIS Manager on the Director server.
  2. Click the Director site, and then click Application Settings.
  3. Find "Service.AutoDiscoveryAddresses" and ensure that its value is set to the FQDN or IP address of the Controller to be monitored.User-added image
  4. In XenApp 6.5 sites, add “Service.AutoDiscoveryAddressesXA” and ensure that its value is set to the FQDN or IP Address of the XenApp Controller.

Problem Cause

This is due to a configuration issue that might occur when Director is installed on a dedicated server that is remote from the Delivery Controller. It occurs normally in the following scenarios:

Issue/Introduction

Error: "The system is currently unavailable. Please try again later or contact your administrator while logging into Director. Find "Service.AutoDiscoveryAddresses" and ensure that its value is set to the FQDN or IP address of the Controller to be monitored.

Additional Information

Best Practices for Citrix Director