Bnistack error 85 - IOS Socket UNAVAILABLE - not counting retry

Bnistack error 85 - IOS Socket UNAVAILABLE - not counting retry

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Article ID: CTX222941

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Updated On:

Description

Target Devices actively connected to Provisioning Services suddenly exhibit severe performance issues such as:

Target completely hangs
Performance is extremely slow
Number of retries increases dramatically

At the same time the following error is found in the Event Logs inside the Target Device:
Event Log: System
Source: bnistack
Event ID: 85
Text: IOS Socket UNAVAILABLE - not counting retry.
 

Resolution

Investigate the possible causes for the issue from an IP Management perspective.

Provisioning Services versions later than 5.x do not support changing or releasing the IP of an active Target Device.
Among the Best Practices for PVS Environments is to configure DHCP Lease times to unlimited to prevent any change in IPs on an active Target Device.

In addition to the IP itself, the Target Device's Network Adapter could also be a source of the problem.
If the Target Device is a Virtual Machine, logs in the Hypervisor Host can be analyzed to confirm there aren't any problems with the Virtual Network Adapter.
On physical Target Devices the Network Adapter can be temporarily replaced to test for Hardware issues.

Problem Cause

This issue can happen when the bnistack driver is unable to open, or use a previously available, network socket.

The most common cause for this issue is releasing or changing the IP address of the Network Adapter being used to communicate with the PVS Server.
Hardware related problems with the Network Adapter itself can also cause this problem.