Xendesktop XDDS:9509EEA3 : Licensing does not work when configured for TLSv1.2

Xendesktop XDDS:9509EEA3 : Licensing does not work when configured for TLSv1.2

book

Article ID: CTX222821

calendar_today

Updated On:

Description

Steps to reproduce :

Secure the connection using TLS v1.2 between the Delivery Controller (XenDesktop 7.9) and the Licensing server (version 11.14) 
referring  https://support.citrix.com/article/CTX200265 Below is the error we get 


User-added image

Environment

Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.

Resolution

This is a known bug, the issue was introduced after we published the docs for the XenDesktop version, hence to fix the problem try the following :

With XenDesktop 7.9 +TLSv1 works however +TLSv1.1 and +TLSv1.2 fail, So inorder to use later TLs versions we need to upgrade the Xendesktop version to 7.11 or above and License server to 11.14 or above.


Problem Cause

Known bug with product