Public store application on XenMobile gives error "500 server internal error "
book
Article ID: CTX222637
calendar_today
Updated On:
Description
There are can be multiple scenarios in which the issue can come
- When publishing the public store app “Archibus Client” (https://itunes.apple.com/au/app/archibus-mobile-client-2.0/id926252726?mt=8), the application details can be populated in XM console but the “500 Server Internal Error” at the final step “Save”.
- When clicking on "check for updates" for an existing public tore app The XenMobile server gives “500 Server Internal Error”
Environment
Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.
Resolution
You can follow the following steps :
- Remove the description from App
- The google account that is configured on XenMobile console under Google Store Credential , login to google with the account and search for the same app , you should see "This app is compatible with your devices". If in case you see error "the app is not compatible" error ,click on i icon it will tell you the list of devices it is supported with once you have the devices you can add the device id of any of the devices.
- In the following example i am searching for a public store app and can see that the device is compatible with the following 3 devices :
- OnePlus 3T
- Samsung A7
- Samsung galaxy Grand
- So if you have any of these devices in your environment you can add the device ID of the device under the Google Play Credentials on XenMobile.

Problem Cause
- For iOS: We can search the app and when we save it post assigning delivery groups, we get internal 500 error.Removed the description from Application and application got added successfully.
Captured the logs which shows below errors
Exception (exid:15B17E527CD-45538AB6BF6203C28746E90B93B556EB): org.owasp.esapi.errors.ConfigurationException: java.lang.IllegalArgumentException: Classname cannot be null or empty. HTTPUtilities type name cannot be null or empty.
2017-03-28T19:29:09.737-0700 | | ERROR | http-nio-14443-exec-9 | org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/].[Unified console Jersey Web Application] | Servlet.service() for servlet [Unified console Jersey Web Application] in context with path [] threw exception [org.owasp.esapi.errors.ConfigurationException: java.lang.IllegalArgumentException: Classname cannot be null or empty. HTTPUtilities type name cannot be null or empty.] with root cause
java.lang.IllegalArgumentException: Classname cannot be null or empty.
at org.owasp.esapi.util.ObjFactory.make(ObjFactory.java:67)
2. For Android: The device for which the device ID was configured on XenMobile console was not compatible with the application.
Issue/Introduction
This article summarizes the steps that can be followed to when you are getting "500 server internal error " while updating publishing a a public store application
Was this article helpful?
thumb_up
Yes
thumb_down
No