Short sounds are inaudible in ICA session
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Article ID: CTX222588
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Updated On:
Description
Very short sounds (e.g., System Beep on Windows7) played on the VDA are inaudible on the client device.
Resolution
It is depending on Citrix Policy "Audio quality" and client types.
For Windows Client:
- If "Audio quality" is "High(default)", then both LC5842 for VDA for Desktop OS, and LC4941 for Receiver for Windows are required.
- If "Audio quality" is "Low" or "Medium", then only LC4941 for Receiver for Windows is required.
For Linux Client:
- If "Audio quality" is "High(default)", then only LC5842 for VDA for Desktop OS is required.
- If "Audio quality" is "Low" or "Medium", then PlaybackDelayThresh is required to be added to module.ini on the client.
How to add PlaybackDelayThresh to module.ini for Receiver for Linux:
- Open module.ini by the text editor on the client's terminal as super user.
$ sudo vi /opt/Citrix/ICAClient/config/module.ini
- Find "[ClientAudio]", then add "PlaybackDelayThresh=50" as a new line (default=150).
[ClientAudio]
DriverName=VDCAM.DLL
UseThread=TRUE
ThreadQueueSize=32768
PlaybackDelayThresh=50
- Save the change
NOTE: If "Audio quality" is "High(default)" and your VDA already has the fix for LC5842, then do
not add PlaybackDelayThresh=50 because the issue might not be resolved.
Problem Cause
It happens if timing is not same when the audio device on the client is opened/closed and when the audio data is played/stopped. Otherwise VDA does not send audio data.
Issue/Introduction
Very short sounds are inaudible in ICA session
Additional Information
LC4941 has been fixed since
Receiver for Windows 4.4 CU3 and
Receiver 4.6.
LC5842 has been fixed by the private, but CU is not released yet on March, 2017.
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