Unable to Download Content Through a Content Switch
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Article ID: CTX222480
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Updated On:
Description
Customer is using a Content Switch to provide access to a Web Site or Web application.
They notice that when they try to download files through the VIP, the download does not start and reports an error.
Uploads work with no issue.
Issue is seen whether HTTP or SSL is used on the Client side.
Using a Load Balancer to the backend works with no issue
Resolution
Configure a HTTP profile on the NetScaler and Enabled "Drop Extra data from server"
You can leave the rest as default

Then bind this the Services or Service Groups for the Content Switch
Problem Cause
The backend server is returning several segments for the requested file for download.
These segments are adding up to a size larger than what is specified in the Content-Length header.
The NetScaler then drops this response with a reset code of 9217
Additional Information
https://docs.citrix.com/en-us/netscaler/11/system/http-configurations.html
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