ISSUE:
User can not login after changing LDAP authentication to LDAP SSL authentication.
Error message: Invalid user account.
Symptom:
Check the Network Trace and found.
For TLS:
22283 2017-03-09 16:54:29.344825357 2.2.2.2 2.2.2.3 LDAP 232 extendedResp(1) (00000000: LdapErr: DSID-0C090FB4, comment: Error initializing SSL/TLS, data 0, v2580) LDAP_START_TLS_OID
For SSL:
14866 2017-03-09 16:58:03.877887450 *** IP address deleted** TCP 89 636→54389 [RST, ACK] Seq=1 Ack=1 Win=0 Len=0
Root cause:
Per to error code below:
"LdapErr: DSID-0C090FB4, comment: Error initializing SSL/TLS, data 0, v2580"
CA issued cert needs to be implemented.
Solution:
Please configure the LDAP certificate before using LDAPS on Netscaler: