Users Intermittently Unable to Enumerate or Launch Resources

Users Intermittently Unable to Enumerate or Launch Resources

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Article ID: CTX221834

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Updated On:

Description

Users intermittently unable to enumerate or launch resources.  Additionally, internal users are sometimes inappropriately routed through external gateway.

Resolution

Resolving the network configuration resulting in an IP conflict affecting StoreFront load balanced VIP restores access.

Problem identification was complicated by configuration of the StoreFront load balanced VIP as the StoreFront internal beacon.  In this configuration, with the load balanced VIP unavailable, internal users were improperly routed to the external gateway.  Citrix recommends considering a different, highly available, internal only IP for SF beacon to avoid confusion.  Refer to CTX218708 - How to Configure Internal Beacon for Single FQDN on StoreFront for more details.


Problem Cause

IP conflict with StoreFront LB VIP causes intermittent failures enumerating and launching resources.  In addition, LB VIP is used as Storefront internal beacon, causing internal users to route through external gateway inappropriately when unavailable.

Issue/Introduction

Users intermittently unable to enumerate or launch resources. Additionally, internal users are sometimes inappropriately routed through external gateway.