StoreFront 3.9 Install Fails With "Message Exception Has Been Thrown by the Target of an Invocation"

StoreFront 3.9 Install Fails With "Message Exception Has Been Thrown by the Target of an Invocation"

book

Article ID: CTX221563

calendar_today

Updated On:

Description

StoreFront installation fails with no errors.

Event Id 0 "Message exception has been thrown by the target of an invocation"

User-added image

In StoreFront "Citrix-DeliveryServicesRoleManage" logs, you find

[Error] Unexpected exception. Message: Exception has been thrown by the target of an invocation.. Stack Trace =    at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
   at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
   at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at Citrix.Cxmi.CustomSandbox.ManagedDllLoader.CallStaticMethod(String typeName, String methodName, Dictionary`2 methodParams)
   at Citrix.Cxmi.Workflow.ExecuteTask.Execute()
   at Citrix.Cxmi.Workflow.WorkflowSequence.Execute()
   at Citrix.Cxmi.Workflow.WorkflowSequence.Execute()
   at Citrix.Cxmi.Workflow.WorkflowExtension.Run()
   at Citrix.Cxmi.Core.Engine.Run()
   at Citrix.Cxmi.Core.Program.Main(String[] args).
 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

- Make sure that the installation files from previous failed install of StoreFront are completely removed.
C:\Program Files\Citrix\Receiver StoreFront
C:\ProgramData\Citrix

+C:\Program Files\Citrix\Receiver StoreFront\Scripts_ClearUP_1.ps1
+C:\Program Files\Citrix\Receiver StoreFront\Scripts_ClearUP_2.ps1
 
- Delete reg key HKLM\SOFTWARE\CITRIX\Roles
NOTE: do take a backup of the reg-key.

Problem Cause

Registry entry from previous failed install of StoreFront causing issues with new StoreFront install.