Logo area of a document is printed as a black square in SAP printing use case
book
Article ID: CTX220797
calendar_today
Updated On:
Description
Customer uses published SAP application to send print job to client printer via Citrix Universal Printer Driver. However, the company logo area in the document is always printed out as a black square.
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
Configure below SAP registry in Server VDA for each XenApp login user
Path: HKEY_CURRENT_USER\Software\SAP\SAPlpd\SAPLPD\
Name: transparent_bitmaps
Type: DWORD
Data: 0
Configure and apply below Citrix Policy setting:
ICA/Printing/Universal Printing/Universal printing optimization defaults: Uncheck "Allow caching of embedded images"
Problem Cause
SAP Printing module should encounter some errors when processing bitmap area of the print job with
Citrix Universal Printer Driver, which caused the bitmap area is removed from the print image object and finally shown as a black square.
Issue/Introduction
The article describes a Citrix printing issue in published SAP application.
Was this article helpful?
thumb_up
Yes
thumb_down
No