Users not able to launch published applications with error <Application Name> failed to start.The Citrix server is unable to process your request to start this published application at this time. Please try again later.

Users not able to launch published applications with error <Application Name> failed to start.The Citrix server is unable to process your request to start this published application at this time. Please try again later.

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Article ID: CTX220593

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Updated On:

Description

Users not able to launch published applications and getting error : <Application Name> failed to start. The Citrix server is unable to process your request to start this published application at this time. Please try again later. If the problem persists, contact your administrator.

There is no issue in launching published desktop.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Add or set the following registry key on the XenApp server(s) if not already present to resolve the issue.

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

Registry Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wfshell\TWI
Name: DllName
Type: REG_SZ
Value: seamls20.dll

Name: NotifyEvent
Type: REG_SZ
Value: WfshellTwiNotify

Note: By default the above registry entries should be present and this registry entry needs to be created if it does not already exist.
 


Problem Cause

Any customization such as any script pushing change to the TWI registry key may lead to delete the required values from TWI registry causing the error during application launch. 

Additional Information

https://support.citrix.com/article/CTX132243