book
Article ID: CTX220429
calendar_today
Updated On:
Description
When Filtering keywords are set incorrectly on Desktops, Enumeration will fail and Desktops will not be filtered accordingly. This feature was introduced in StoreFront 2.5.
Resolution
- Launch Citrix Studio
- Go to Delivery Group Node and select one of your Delivery Groups, right click on it and select Edit Delivery Group
- Select "Desktop" option on the left pane and then click on the right pane and select the Desktop.
- Select "Edit"
- Inside the Edit Desktop Window, go to the "Description" Field and enter the desired Keyword there. In the example below we are using "Support" as the Keyword
- Click Apply and OK
- Once this operation is completed, you can enable keyword filtering on the StoreFront Server.
To enable Keyword filtering using Powershell please follow the steps described in
https://docs.citrix.com/en-us/storefront/current-release/advanced-configurations/configure-resource-filtering.htmlNOTE: Keyword based resource filtering will not work for dedicated machines and is NOT supported.
Problem Cause
When Keyword filtering fails on Desktops and are not enumerated on StoreFront based on Keyword configuration specified on XenDesktop, it is generally based on Keyword being entered in the wrong field.
When configuring / Creating or editing a Delivery Group in XenDesktop there are is another place in which a Description field is seen and that is under > Edit Delivery Group > User Settings. If Keyword is specified here StoreFront will not be able to read this, Therefore, Keyword will not be recognized and enumeration will fail depending on the settings specified for keyword filtering on the StoreFront Server.
Issue/Introduction
Explains how to filter enumeration resources based on keywords. This will allow StoreFront to filter these resources based on the keywords used for Desktops.