When User Profile Manager is Enabled a Prompt Appears "How do you want to open this type of link (http) ?"

When User Profile Manager is Enabled a Prompt Appears "How do you want to open this type of link (http) ?"

book

Article ID: CTX220134

calendar_today

Updated On:

Description

User Profile Manager is enabled. Inside a published desktop launch Outlook .Then click on an email address link  (MAILTO) or on a Hyperlink (HTTP/HTTPS) a popup dialog appears with options for "Citrix Metaframe Server FTA" , "Internet Explorer" or "Look for an app.."


User-added image

Once an option is selected the choice  is saved in the UPM profile and the question is never posed again on subsequent launches. However it is desired that the user never sees the prompt and that "Internet Explorer" is selected by default.

This prompt is not seen if outlook is installed in an RDP session or if UPM is not enabled in an ICA session.
 

Resolution

As a workaround create the initial registry FTA entries with a local policy so that the FTA choice is set when the profile is created.

1. Choose a target machine with the same OS as the VDA.
Set the file type associations as desired in control panel.
Here set HTTP and HTTPS to use Internet Explorer.

IE Default


2. Run the command Dism /Online /Export-DefaultAppAssociations:C:\AppAssocAttac.xml (this will create a XML file with the configurations of default programs for different file extensions )

Create a GPO or a local policy.
 
3.   Expand to the policy location , Computer configuration\Policies\Administrative Templates\Windows Components\File Explorer. 
4.   On the right side pane select the policy “Set a default associations configuration file” 

User-added image
5.   Click on Enabled and then give the path of XML file in the options area. 

6.  Save settings and exit the policy editor enable loopback processing 

7.   Apply the policy to the OUs where the servers are placed. 
On VDA run  gpupdate /force so that changes would take effect immediately.

8.   Run RSOP.msc in the servers, and make sure the policies are properly applied.

9. Launch new HDX session . Try to open the link in Outlook. There is  no longer any prompt to open a http or https link whether in  Outlook or Wordpad.


Problem Cause

FTA registry entries are not created.

Additional Information

https://blogs.technet.microsoft.com/mrmlcgn/2013/02/26/windows-8-associate-a-file-type-or-protocol-with-a-specific-app-using-gpo-e-gdefault-mail-client-for-mailto-protocol/