License Server Error: No Licenses Available for Specified Server Type

License Server Error: No Licenses Available for Specified Server Type

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Article ID: CTX219756

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Updated On:

Description

When the XenServer is attempted to be licensed you may come across error "The license-server did not issue a license for server "servername" because there were no license for the specified type available"

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Resolution

 

  • Check the date and time on the XenServer which is being attempted to be licensed through the command line interface using the command date, if in case it is incorrect and that is why probably causing the issue
    • You can set the correct date and time using the command date –s “DD MMM YYYY HH:MM:SS”  (Month in format MMM ex. JAN,FEB,MAR...)
  • Make sure XenServer licenses shows up correctly on the license server along with the Citrix start up license file. If no, reallocate the licenses, delete the old license files and install the new license file.
  • Check if the XenServer is compatible with the License server
  • Select the correct Edition while assigning the licenses on the Xencenter based on the licenses that you have on the License server
  • Check on the XenServer if the port 27000, 7279 is open
  • Run xe-toolstack-restart command on the XenServer. This will disconnect the XenServer from XenCenter, however Virtual Machines will not be affected

Problem Cause

Incorrect date and time on the XenServer

Additional Information

http://sweeneyops.wordpress.com/2011/11/15/manually-setting-the-time-in-citrix-xenserver/