XenApp 6.5: AppCenter: Error Modifying or Deleting an Application

XenApp 6.5: AppCenter: Error Modifying or Deleting an Application

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Article ID: CTX219741

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Updated On:

Description

When attempting to modify or delete an application from AppCenter, the following error message is displayed: Your configuration change cannot be made because the logging database is unavailable.

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Resolution

1. Open the Component Services snap-in (comexp.msc).
2. Expand Component Services > My Computer > COM+ Applications.
3. Right-click CitrixLogServer, select Properties, then select the Security tab.
4. Uncheck the "Enforce access checks for this application" check box.

Problem Cause

The IMA service used by the Access Management Console to communicate with the Configuration Logging Database had been configured to run in the security context of the Local System account instead of the one used by default in XenApp 4.5 Network Service account. This configuration is no longer used or supported starting from XenApp version 4.5 for product design and security reasons.
 

Issue/Introduction

When attempting to modify or delete an application from AppCenter, the following error message is displayed: Your configuration change cannot be made because the logging database is unavailable.