ICA Sessions get stuck at Prelogon with blank Current User or Associated User name in Citrix Studio and Director

ICA Sessions get stuck at Prelogon with blank Current User or Associated User name in Citrix Studio and Director

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Article ID: CTX219511

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Updated On:

Description

  • Intermittently you see sessions with no current user and associated user name in Citrix Studio and Director. Current User and Associated User fields are blank in Cirix Studio and Director.
  • You see the VDA machine name where the connection was routed in Citrix Studio and also see the Client Machine's name and IP Address from where the session was initiated in Citrix Director.
  • If you run Get-BrokerSession powershell cmdlet on the Delivery Controller, you see that LogOnInProgress is True, SessionfState shows Connected. The Appstate is shown as prelogon/desktop instead of Active. This output also shows the associated BrokeringUserSID, BrokeringUserName , BrokeringTime , SessionKey , ClientName and Client IP along with Xendesktop/XenApp Server and DeliveryController's name which can be used to identify that session.
  • On the target Xendesktop/XenApp Server you do not see any associated session or process for that user as the session is not completely established yet.
  • You can RDP to the target Xenapp/Xendesktop server but no further ICA sessions can be established on the corresponding VDA against which you see such sessions.
  • Temporary workaround is to restart the Citrix Desktop Service on the effected VDA server post which these sessions gets cleared out and new ICA sessions can be established.

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User-added image


 

Resolution

Since customer had installed Per User RDS CALS on RDS Licensing server, we rectified the Licensing mode from Per Device to Per User on the Virtual Desktop Agents (Xenapp/Xendesktop servers) and after that no sessions were getting stuck at Prelogon.

Problem Cause

Incorrect Remote Desktop Services Licensing Mode was specified on the VDA machines. Customer had purchased Per User RDS CALS but had specified Per Device Licensing mode on the VDA servers.

While investigating why the sessions that were stuck at “LogonInProgress” we found the below Licensing events being logged on the effected VDAs.

 
Log Name: System
Source: Microsoft-Windows-TerminalServices-RemoteConnectionManager
Date: 11/16/2016 11:37:13 PM
Event ID: 1011
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
Computer: xxxxxx
Description:
The remote session could not be established from remote desktop client xxxxx because its temporary license has expired.

Log Name: System
Source: Microsoft-Windows-TerminalServices-RemoteConnectionManager
Date: 1/5/2017 8:40:45 AM
Event ID: 1028
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
Computer: xxxx
Description:
The remote session could not be established from remote desktop client xxxxx because its license could not be renewed.

You can look for other RDS Licensing errors or warnings as well. Please note that sessions get stuck at prelogon state because of various reasons. RDS Licensing issue is just one of them.

Data to be collected in such scenarios:

 1.Scout Logs from effected Xendesktop and DDC’s. 
2. CDF logs from effected Xendesktop and DDC’s
3. 
Screenshot of Studio and Director showing the session without any associated username and the client machine name.
4. Output of below commands from Delivery Controller.

Get-BrokerMachine​

Get-BrokerSession -DesktopGroupName GROUP_NAME –LogonInProgress $true
 
Get-BrokerSession -DesktopGroupName GROUP_NAME


 

Issue/Introduction

ICA Sessions get stuck at Prelogon with blank Current User or Associated User name in Citrix Studio and Director

Additional Information

https://technet.microsoft.com/en-us/library/cc754487(v=ws.11).aspx

https://blogs.technet.microsoft.com/askperf/2013/09/20/rd-licensing-configuration-on-windows-server-2012/