NetScaler Gateway EPA Scan Fails When Checking for "Windows Update" on Client Machine

NetScaler Gateway EPA Scan Fails When Checking for "Windows Update" on Client Machine

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Article ID: CTX219293

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Updated On:

Description

When NetScaler Gateway EPA scan is configured to validate if the Windows update on client machine has been performed within X days, the scan fails on client machine.

Environment

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Resolution

To resolve this issue, navigate to Control panel > Windows update > Change Settings > Select Install Updates Automatically (recommended) as shown in the following screen shot:

User-added image

In the epaHelper_epa_plugin logs, you will find the below highlighted messages when the EPA fails for Windows update. The location of epaHelper_epa_plugin is "C:\Users\<UserName>\AppData\Local\Citrix\AGEE"
Note: AppData will be hidden by default. To view it, go to View > Options > Change folder and view options > View > Show hidden files and folders > Apply.

=========================
EPA library log file
Version: 1,1,1,24
Date: 11/18/2016
Time: 11:00:23
=========================
11:00:23.390 setConfig got called with allowLogging 1 and configString lang=en
11:00:23.390
---------Next Scan---------------
11:00:23.390 Successfully parsed tokens
11:00:23.397 Agent service is enabled
11:00:23.398 Windows update is set to disabled or not-configured
11:00:23.398 LastSearchSuccessDate failed or update scan was never performed
11:00:23.398 Couldn't get Agent information
11:00:23.398 Scan failed for Scan method SCAN-TIME
scanQuery : WIN-UPDATE_SCAN-TIME_<=_300
11:00:23.422 getScanErrorText called
11:00:23.966 Doing Cleanup

Problem Cause


As per Microsoft, the " The Automatic updates" will update the Last Search Success Date results. Since Windows update was not set to " Automatic" on client machine, the Last Search Success Date results was not updated. Thus EPA fails.

Issue/Introduction

When NetScaler Gateway EPA scan is configured to validate if the Windows update on client machine has been performed within X days, the scan fails on client machine.

Additional Information

https://msdn.microsoft.com/en-us/library/windows/desktop/aa826440(v=vs.85).aspx