Error "Citrix XenApp failed to connect to the Data Store. ODBC error while connecting to the database" after TLS v1.2 Enabled

Error "Citrix XenApp failed to connect to the Data Store. ODBC error while connecting to the database" after TLS v1.2 Enabled

book

Article ID: CTX219230

calendar_today

Updated On:

Description

Disabling TLS v1.0 on Server 2008 r2 and enabling TLS v1.2  cause database connection errors

"Citrix XenApp failed to connect to the Data Store. ODBC error while connecting to the database: 08001 -> [Microsoft][ODBC SQL Server Driver][DBNETLIB]SSL Security error" 

User-added image

Resolution

  1. Installed Microsoft ODBC Driver 11 for SQL Server on XenApp server  
  2. Created new DSN file pointing to new client driver [ Advanced Concepts - XenApp Farm Maintenance ] pointing to new SQL Client Driver
User-added image

3. Recreate local host cache

Problem Cause

The client drivers that have support for TLS 1.2 for for SQL Server 2008 and SQL Server 2008 R2 need to be at least SQL Server Native Client

Additional Information

https://blogs.msdn.microsoft.com/sqlreleaseservices/tls-1-2-support-for-sql-server-2008-2008-r2-2012-and-2014/