WEM admin console fails to connect with error: Error while connecting to the specified Infrastructure Server
book
Article ID: CTX219045
calendar_today
Updated On:
Description
The WEM Administration Console errors out while connecting to the broker with a generic error: "Error while connecting to the specified Infrastructure Server".
Looking into the the WEM admin console debug logs (%userprofile%\Citrix WEM Console Trace.Log) the following error is reported:
Exception -> ConnectToBroker.Run() : System.ArgumentException : Value was invalid.
Parameter name: sddlForm
Environment
The above mentioned sample code is provided to you as is with no representations, warranties or conditions of any kind. You may use, modify and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the sample code may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the sample code fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the sample code. In no event should the code be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SAMPLE CODE, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Although the copyright in the code belongs to Citrix, any distribution of the sample code should include only your own standard copyright attribution, and not that of Citrix. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the sample code.
Resolution
Create a full backup of the WEM database and then run the following query on the SQL server where the WEM database is hosted:
USE <WEMDatabaseName>
BEGIN TRAN
-- This will return corrupt entries in the dbo.VUEMUser table that do not have a SID format:
SELECT * FROM VUEMUsers WHERE Name LIKE '%\%'
-- Once identified the entries that do not have a SID format, they have to be deleted:
DELETE FROM VUEMUserStatistics WHERE UserId IN (SELECT IdUser FROM VUEMUsers WHERE Name LIKE '%\%')
DELETE FROM VUEMUsers WHERE IdUser IN (SELECT IdUser FROM VUEMUsers WHERE Name LIKE '%\%')
COMMIT
NOTE:
To see the corrupt entries without deleting them yet, highlight the first SELECT consult only and then click the Execute button, or do right click and select Execute. Then, to run the full query highlight it completely and click Execute.
Problem Cause
Corrupt entries found in the Name column of the VUEMUsers table in the WEM database. When attempting to read the user statistics, the console cannot translate the corrupted entries as they do not have the correct SID format and thus errors out.
Additional Information
One of the potential causes of the corrupt SID recording is a malfunctioning of the Netlogon service on a server which is mistakenly identified as having opened a session with an incorrect SID. If the issue re-occurs, compare the LastAgentId of the corrupt SID user record with the VUEMAgents table to determine which server the recording is coming from, then restart the Netlogon service there.
***DISCLAIMER***: This is a 3rd party URL and is meant for reference only - SQL Queries should be run by SQL DB Administrators
Was this article helpful?
thumb_up
Yes
thumb_down
No