Error: "Server sent back a fault indicating it is too busy to process the request" and the WEM Agent fails to connect to the Broker Service

Error: "Server sent back a fault indicating it is too busy to process the request" and the WEM Agent fails to connect to the Broker Service

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Article ID: CTX218965

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Updated On:

Description

The Citrix Workspace Environment Management Agent fails to connect to the Norskale Infrastructure Service, and the Citrix WEM Agent Service log contains the following error:

ConfigurationDataSourcesHelper.CheckAgentBrokerServiceClient() : System.ServiceModel.ServerTooBusyException : Server 'net.tcp://[brokername]:[port]/AgentBrokerSvc/service' sent back a fault indicating it is too busy to process the request. Please retry later. Please see the inner exception for fault details

Resolution

#1:  Stop the Norskale Infrastructure Service on the WEM Broker server

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#2:  Locate the "Norskale Broker Service.exe.config" configuration file in the broker installation directory (by default , it is here:   C:\Program Files (x86)\Norskale\Norskale Infrastructure Services") and create a backup copy of this file.
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#3:  Open the original config file with a text editor as Administrator, locate the following two lines:
<serviceBehaviors>
<behavior name="">


Add the following line immediately below the <behavior name=""> tag:
<serviceThrottling maxConcurrentCalls="2000" maxConcurrentSessions="2000" maxConcurrentInstances="2000"/>

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#4:  Save these changes, then restart the Citrix WEM Broker Service.

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Problem Cause

This error occurs when the broker's hardware specifications are insufficient to allow it to open enough concurrent threads to serve every request made by incoming agent service connections.