Error: "The Citrix WEM Agent Host Service service hung on starting", Netlogon prevented from starting

Error: "The Citrix WEM Agent Host Service service hung on starting", Netlogon prevented from starting

book

Article ID: CTX218963

calendar_today

Updated On:

Description

The Citrix WEM Agent Host Service fails to start with the following error message: "The Citrix WEM Agent Host Service service hung on starting."

As a result, the Netlogon service is prevented from starting because Netlogon depends on the Citrix WEM Agent Host Service

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Open regedit on the affected desktop or server running the Citrix Workspace Environment Management Agent. 

Browse to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WemAgentSvc


Then add "Winmgmt" to the DependOnService value (without removing EventSystem).


Problem Cause

The WMI service failed to start before the Citrix WEM Agent Host Service attempted to start.