Seamless application window turns black when Windows peek is invoked and another seamless application

Seamless application window turns black when Windows peek is invoked and another seamless application

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Article ID: CTX218924

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Updated On:

Description

A specific application hosted on 2008R2 XenApp 7.11 connecting with Receiver 4.5 on Windows 7, when the application has a second window in front and is previewed on the Win7 client device by hovering over the taskbar icon, the application goes black.

Object: 2008 R2 SVDA 7.11

Deviation: Getting black screen when Windows Peek is used to toggle between two seamless apps.

Resolution

Disable Windows Dynamic Preview policy setting via Citrix Studio policy and giving it a higher priority than the Unfiltered policy fixes the issue.

Reference Document: Graphics policy settings - search for "Dynamic windows preview" https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-6/xad-policies-article/xad-policies-settings-wrapper/xad-policies-settings-ica/xad-policies-settings-graphics.html

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Problem Cause

Windows Dynamic Preview policy setting is enabled by default. This setting when enabled automatically enables the Windows Peek option (When the user hovers over a taskbar preview image, a full-sized image of the window appears on the screen.) causing the issue; source: https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-6/xad-policies-article/xad-policies-settings-wrapper/xad-policies-settings-ica/xad-policies-settings-graphics.html

The Windows peek option causes the behavior

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Additional Information

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