Authorizing FAS fails with error "The Request Channel Timed out while waiting for a reply after 00:01:00"

Authorizing FAS fails with error "The Request Channel Timed out while waiting for a reply after 00:01:00"

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Article ID: CTX218579

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Updated On:

Description

Unable to Authorize the FAS service, fails with the error "The Request Channel Timed out while waiting for a reply after 00:01:00" .
Below is the screen shot of the error.

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Resolution

Delete all the stale or old certificate authority server information by following the below steps to resolve the issue.
  1. On one of the domain controllers.
  2. Go to Start -> Run
  3. Type adsiedit.msc and press enter.
  4. Now on the left pane of the mmc, right click on ADSI Edit and click on connect to.
  5. It will open up a connection settings dialog box.
  6. In the connection settings dialog box under "Select a well know Naming Context" drop down select "Configuration" and click ok.
  7. On the left pane, you will see the Configuration Partition loaded.
  8. Double click on the Configuration and navigate to the following location to delete the stale or old CA server entries.
          CN=Enrollment Services,CN=Public Key Services,CN=Services,CN=Configuration,DC=yourdomain,DC=com.

 

Problem Cause

When Authorizing the FAS, it is going to query the following Active Directory partition to get the Certificate Authority Server Information to enroll the certificate.

CN=Enrollment Services,CN=Public Key Services,CN=Services,CN=Configuration,DC=yourdomain,DC=com.

If there are stale entries or old CA servers listed there, it is going to query all the servers and not knowing which one is the correct one. The time out happens because of this reason.

Issue/Introduction

Authorizing FAS fails with error "The Request Channel Timed out while waiting for a reply after 00:01:00" when trying to submit the certificate request to the CA server.