Printers Do Not Enumerate - Apps Freeze When Trying to Print

Printers Do Not Enumerate - Apps Freeze When Trying to Print

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Article ID: CTX218023

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Updated On:

Description

When printing from the published app, Print window does not pop up (Printers do not enumerate) and application hangs. If we restart the spooler service on the XenApp host, the print window comes up asking to install printers.

 

Environment

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Resolution

Microsoft has provided the following solution.

Please find below the Action Plan that resolved the reported issue: 

1. Directly remove the PCL6 Driver for Universal Print driver from the Print Management console if possible. 

2. If unable to remove the Print driver in question from PMC, please remove the Client Side Rendering Print Provider registry key after backing up a copy of same: 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider 

3. Restart the Print Spooler Service. 

4. Retry removing the PCL6 Driver for Universal Print driver. 

5. Install the latest version of Ricoh PCL6 Driver. 

6. Reboot the machine. 

7. Reproduce the issue. 


Problem Cause

Problem cause was PCL6 Universal Print Driver.

Per Citrix analysis:

  • Session 8 , notepad.exe process thread is waiting for ALPC reply from server thread of spoolsv.exe.
  • In the Spoolsv.exe process address space there is ALPC wait chain spoolsv -> Printisolation ->spoolsv
  • Server thread of spoolsv.exe process blocked on call  “spoolsv!EnumPrintersW”.
Waiting for reply to ALPC Message fffff8a008784780 : queued at port fffffa800b04d950 : owned by process fffffa800adfcb10
       
00000000`000de330 000007fe`fa98bae5 : 00000000`00010088 000007fe`fe7710d7 00000000`00000000 00000000`000de460 : WINSPOOL!RpcEnumPrinters+0x4a
       
00000000`000de390 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : WINSPOOL!EnumPrintersW+0xf9
 
 
QueueType             : ALPC_MSGQUEUE_PENDING
QueuePort             : fffffa800b04d950 [ALPC_CONNECTION_PORT]
QueuePortOwnerProcess : fffffa800adfcb10 (spoolsv.exe)
ServerThread          : fffffa800d0d8b50

Issue/Introduction

When printing from published app, Print window does not pop up (Printers do not enumerate) and application hangs. If we restart the spooler service on the XenApp host, print window comes up asking to install printers.