SF Web Page inaccessible after changing Base URL

SF Web Page inaccessible after changing Base URL

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Article ID: CTX217674

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Updated On:

Description

- Once the SF is configured, there might be a need to change the Base URL. However, the SF page becomes inaccessible and throws below error

User-added image
- You might also get "Cannot complete your request" on this page.

 

Resolution

Assuming here, that the Base URL is not an FQDN but just some name, example > labdesktops > instead of the SF FQDN name.

1. In DNS, create a CNAME record
2. In Alian name field, add the new SF Base URL (labdesktops).
3. Add the FQDN of the SF server in FQDN host field.
4. Refresh the SF web page to see the page displaying credentials box.

Problem Cause

1. The new Base URL cannot resolve to anything by just changing it.
2. We need to map this in DNS to the FQDN of the SF server.

Issue/Introduction

Often there is a change in Base URL and that can result in seeing the SF web page unable to access or getting "Cannot complete your request".