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Article ID: CTX217456
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Updated On:
Description
NOTE: This article contains information about UPDATING a Catalog ONLY.
For information on CREATING a Catalog see: CTX140734
Updating a catalog might fail during Image Preparation because of many reasons. In order to identify what caused the failure we need to collect preparation Image logs according to article CTX140734 - Error: “Preparation of the Master VM Image failed” when Creating MCS Catalog in XenApp or XenDesktop.
However, after running the commands from the preceding article successfully, the Preparation Image Shuts down and we are not able to collect the logs.
Environment
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Resolution
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Run Get-ProvScheme and identify the Provisioning Scheme associated with the catalog in question (Provisioning Scheme name is same as the name of the catalog).
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Make a note of the "ProvisioningSchemeUid" associated with the catalog.
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Run the command "Set-ProvSchemeMetadata -ProvisioningSchemeUid xxxxxxx -Name ImageManagementPrep_NoAutoShutdown -Value $True.
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Now, enable logs on the master image according to the article CTX140734 and start the catalog Update
Additional Steps that are performed during image Preparation
During the Image Preparation following steps are performed by MCS
- Enable DHCP
- Microsoft Windows KMS Rearm
- Microsoft Office KMS Rearm
- Personal vDisk Inventory Collection
- In Command Prompt Admin run del %WINDIR%\smscfg.ini
- In PowerShell run Remove-Item -path HKLM:\Software\Microsoft\SystemCertificates\SMS\Certificates\* -Force
- Unjoin device from Azure Active Directory
The following methods can be used to solve the problems during the Image Preparation
Skip "Enable DHCP":
- Run the command "Set-ProvSchemeMetadata -ProvisioningSchemeUid xxxxxxx -Name ImageManagementPrep_Excluded_Steps -Value EnableDHCP
Skip "Microsoft Windows KMS Rearm"
- Run the command "Set-ProvSchemeMetadata -ProvisioningSchemeUid xxxxxxx -Name ImageManagementPrep_Excluded_Steps -Value OsRearm
Skip "Microsoft Office KMS Rearm"
- Run the command "Set-ProvSchemeMetadata -ProvisioningSchemeUid xxxxxxx -Name ImageManagementPrep_Excluded_Steps -Value OfficeRearm
Solve issues that occurred during the step of “Unjoin device from Azure Active Directory”:
Problem Cause
Commands described in the article CTX140734 will work only while creating new catalogs (New provisioning scheme) as it describes the metadata values for new provisioning schemes. When going for a catalog update, the existing provisioning scheme associated with the catalog is used, hence the metadata values for the existing provisioning scheme have to be changed.
Additional Information
1.
https://www.citrix.com/blogs/2016/04/04/machine-creation-service-image-preparation-overview-and-fault-finding/ - This blog points to commands that can be used to perform the above actions when the issue is seen during catalog creation
- The blog referenced above uses the command Set-ProvServiceConfigurationData and this article uses the command Set-ProvSchemeMetadata
- Explanation for the commands
- Set-ProvServiceConfigurationData – This command adds metadata values to a new prov scheme, i.e. when a new catalog is created (a new prov scheme is created), the values defined with the help of this command will take effect
- Set-ProvSchemeMetadata – This commands changes the metadata values of an existing prov scheme, i.e. an existing catalog
2. CTX140734 -
Error: “Preparation of the Master VM Image failed” when Creating MCS Catalog in XenApp or XenDesktop.