Hotfix installation fails with the following error"Installation ended prematurely because of an error". Error 1603: A fatal error occurred during installation

Hotfix installation fails with the following error"Installation ended prematurely because of an error". Error 1603: A fatal error occurred during installation

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Article ID: CTX217301

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Updated On:

Description

When trying to install any Xenapp update it ends with error 1603.
Hotfix installation fails with the following error"Installation ended prematurely because of an error".

Resolution

Complete the following steps to resolve this issue:

1.Before starting the installation ,make sure that the following services are started:
  - Distributed Transaction Coordinator Service. 
  - Windows Installer Service 

2.Reboot the server in question so that we do not have any pending reboots.Try the installation now.
   If this does not help ,proceed to the next step.

3.Try resetting the MSDTC log.
  • From a command prompt run “msdtc -uninstall” without the quotes. 
  • Verify the DTC was uninstalled successfully by reviewing the application event log. 
  • Open regedit and ensure the following registry keys have been deleted (they all may not be present): 
  1. HKEY_CLASSES_ROOT\CID (not present) 
  2. HKEY_CLASSES_ROOT\CID.Local for Windows 2008 (not present) 
  3. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSDTC (it was present; exported the key and then deleted it) 
  4. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSDTC not present 

- Reboot the machine. 
- From a command prompt run “msdtc -install” without the quotes. 
- From a command prompt run “msdtc -resetlog” without the quotes. 
- In the Administrative tools, Services verify the Distributed Transaction Coordinator service is started and then change the properties of the service so the startup type is “automatic." 
- Also, remember to go into Component Services and change the security settings for the DTC to match the other machines. 
- Rebooted the server. 
- The service was up MSDTC. 

   Try installing the hotfix again and in case this fails. Follow the next step.

4.Collect the MSI Logs while reproducing the issue.
   - To enable Windows Installer logging yourself, open the registry by using Regedit.exe, and then create the following subkey and keys:
  1. HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer
  2. Reg_SZ: Logging
  3. Value: voicewarmupx
Note This change should be used only for troubleshooting and should not be left on because it will have adverse effects on system performance and disk space. Each time that you use the Add or Remove Programs item in Control Panel, a new Msi*.log file is created.

Problem Cause

Some remnants of the installation might remain in the system whenever an installation does not complete or roll back successfully. Windows Installer runs only one installation at a time, only one installation is active at any given time and there is only one instance of the indicator objects on any system.Therefore it is important that the Windows Installer and MSDTC service are running all the time during the installation and they do not have any pending action.

Issue/Introduction

We face issues while installing or upgrading Hotfix Rollup Packs in XenApp 6.0 ,6.5. Error 1603: A fatal error occurred during installation

Additional Information

Hotfix Install/Uninstall or XenApp Repair Ended Prematurely on XenApp 5.0/6.0/6.5 : http://support.citrix.com/article/CTX139240
How to enable Windows Installer logging : https://support.microsoft.com/en-us/kb/223300
How to reinstall MS DTC : https://support.microsoft.com/en-us/kb/279786
Hotfix Install/Uninstall or XenApp Repair Ended Prematurely on XenApp 5.0/6.0/6.5 : http://support.citrix.com/article/CTX139240
When Trying to Install or Remove XenApp Software, a 1603 Error Message is Displayed : http://support.citrix.com/article/CTX132117