Secure Hub could not connect to Store

Secure Hub could not connect to Store

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Article ID: CTX217040

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Updated On:

Description

Some users unable to open Store, getting error message Store could not connect.

Resolution

Delete affected devices and re-enroll.

Problem Cause

Trace showed "Duplicated devices" as part of a 403 response to the storeweb 

Querying the DEVICES table for the X-Citrix-Device-ID from trace result in two hits. This means two users/devices are using the same MAM id. 
Deletion of both devices, then re-enrol resolved the issue
 

Additional Information

https://support.citrix.com/article/CTX217692