NetScaler : Recieves Error - "Undefined SAML error" when an SAML Authentication Request is received

NetScaler : Recieves Error - "Undefined SAML error" when an SAML Authentication Request is received

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Article ID: CTX216848

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Description

NetScaler is configured as  SAML IDP.
NetScaler :  Recieves Error - "Undefined SAML error" when an SAML Authenticaton Request is received

Resolution



Validate incoming SAML authentication request. Verify the SAML binding on the SAML IDP and SP are matching. 

To validate the SAML request you will need to use developer tools within a browser such as Chrome or Firefox. Alternatively,  a proxy such as Fiddler can be used. On the NetScaler, enable debug level logging

The browser request will show the following:
<samlp:AuthnRequest
    AssertionConsumerServiceURL='https://sp.provider.org/testmy/saml/page'
    Destination='https://idp.example.org/saml/login' ID='_1b8ebdd0-7f9c-0134-a66f-12ae381cc4a7'
    IssueInstant='2016-10-29T00:25:24Z' Version='2.0' xmlns:saml='urn:oasis:names:tc:SAML:2.0:assertion'
    xmlns:samlp='urn:oasis:names:tc:SAML:2.0:protocol'>
    <saml:Issuer>https://sp.provider.org/howboutallthat/saml/metadata</saml:Issuer><samlp:NameIDPolicy AllowCreate='true'
        Format='urn:oasis:names:tc:SAML:1.1:nameid-format:emailAddress'/></samlp:AuthnRequest>

The following will be seen in the NetScaler logs:

collector_P_1.1.1.1_27Oct2016_10_42/var/log/ns.log:Oct 27 10:04:23 <local0.debug> 10.203.5.6 10/27/2016:10:04:23   0-PPE-2 : default AAATM Message 3688098 0 :  "SAML verify digest: digest algorithm SHA1, input for digest: <samlp:AuthnRequest xmlns:samlp="urn:oasis:names:tc:SAML:2.0:protocol" Destination="https://idp.example.org/saml/login" ForceAuthn="false" ID="_77e17058-eee1-4f48-8417-73b180cbd57b" IsPassive="false" IssueInstant="2016-10-27T15:04:23.203Z" ProtocolBinding="urn:oasis:names:tc:SAML:2.0:bindings:HTTP-POST" Version="2.0"><saml2:Issuer xmlns:saml2="urn:oasis:names:tc:SAML:2.0:assertion">https://sp.provider.org/testmy/saml/page</saml2:Issuer></samlp:AuthnRequest>

In the NetScaler logs, verify that the correct policy for the SAML request is being hit and the the SAML binding is also matching.
 

Problem Cause

Common reasons for this error:

1. Misconfiguration between SP and IDP binding 
2. Incoming authentication request is matched to the wrong policy
 

 

Issue/Introduction

This article discusses on the issue where NetScaler(configured as IDP) throws an error "Undefined SAML error" when a SAML Authentication request is received.