Unable to Delete Device From XenMobile Console

Unable to Delete Device From XenMobile Console

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Article ID: CTX216782

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Updated On:

Description

Deleting a device from XenMobile console reports an error and the device is not deleted from XenMobile console.

Environment

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Resolution

Complete the following steps to resolve this issue:

  1. Selectively wipe the device that you are unable to delete from the XenMobile console.
  2. Authorize the device on XenMobile console by navigating to Device > Secure > Authorize.
  3. Try again to delete the device from XenMobile console.
User-added image

If the steps mentioned above doesn't delete the device successfully, you can delete the device from the XenMobile database by running the following commands :

SELECT * FROM dbo.DEVICE WHERE SERIAL_NUMBER='qwerty1234';

This will show all the records in the table for this serial number. Once confirmed the correct device list you can run the following command to delete the same:

DELETE FROM dbo.DEVICE WHERE SERIAL_NUMBER='qwerty1234';

Note:

  1. Ensure that you take a backup of your database before making any changes to it. 
  2. This article was written for a specific scenario and can only be used as last resort.

Problem Cause

This issue can be caused due to database corruption or duplicate entries within the database. This can occur during XenMobile Server migration.

Issue/Introduction

While deleting a device from XenMobile console, an error is reported and the device is not deleted from XenMobile console.