XMS is unable to connect to DEP - Error: "Connection failed" when testing the connection

XMS is unable to connect to DEP - Error: "Connection failed" when testing the connection

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Article ID: CTX216668

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Updated On:

Description

In the XMS console, inside iOS Bulk Enrollment > DEP Configuration, when importing the Token file from the DEP Portal, the connectivity test is failing with error ("Connection Failed").

However, XMS connectivity tests are showing that XMS is able to reach Apple's websites, the ports are correctly opened both ways, and the XMS SSL certificate is publicly trusted and valid.

Resolution

The local time was incorrect on the XMS server
Corrected this
Rebooted the server
This solved the issue

Problem Cause

Local time was off by 8 minutes on the XenMobile server, causing connectivity to be denied by Apple's server when importing the token file to the console.

Logs were showing a HTTP 400 Bad Request when XMS was trying to connect to DEP:

com.citrix.ios.bulkenrollment.impl.BulkEnrollmentServicesImpl | Received "Session Auth Token" response: BE request result: {httpCode=400, reason='Bad Request', cause='', content='timestamp_refusedBad Request'}