Error: "An Unexpected Error Occurred. " on Receiver 4.4.1

Error: "An Unexpected Error Occurred. " on Receiver 4.4.1

book

Article ID: CTX216561

calendar_today

Updated On:

Description

This article is intended for Citrix administrators and technical teams only.Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information

Receiver 4.4-"An Unexpected Error Occurred. The AuthManager Log or trace files my contain information about the error."

Receiver Diagnostic tool shows the following:

ConfigurationProvider::FetchAccountData:: AuthManager exception caught 65526 : An unexpected error occurred. The AuthManager log or trace files may contain information about the error.


 

Resolution

Manually set the file type associate for ICA file on the workstation.


1. Click the Windows start menu and select Default programs. 

2. Select Associate a file type or protocol with a program. 

3. Highlight the .ICA file type on the list and select change program. 

4. Click Browser and navigate to the following directory C:\Program Files (x86)\Citrix\ICA Client

5. Select Wfcrun32.exe , open, and then ok. 

6. Verify that the file association is set to Citrix Connection manager. 

Problem Cause

Receiver installation was not adding the file type association for wfcrun32.exe to launch applications using the ICA files.