Registration port defaults to 80 after changing to a custom port

Registration port defaults to 80 after changing to a custom port

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Article ID: CTX216493

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Description

Registration port defaults to 80 

Resolution

To have the registration port not accidentally deleted, you can set it in the default settings location – HKLM\Software\Citrix\VirtualDesktopAgent > ControllerRegistrarPort

Problem Cause

The registration port is picked up from the registry (from the policy node, if it doesn’t exist under policies, then it looks at the default settings location), and if not found, it will fall back to the default port of 80. 

So, if the registration was attempted with port 80, that would mean that at that point in time the registration port didn’t exist in the registry.  Probably there was a policy processing failure, or somehow it got deleted before BrokerAgent tried to read it. 

There is no fallback to ‘savedlistofddc’, that is where the registration starts when the BrokerAgent starts (that is if autoupdate is enabled), it will pick a DDC from the list to register with, and when the registration is successful, DDC would send the new list of DDCs, and that list gets saved in the xml file. If all 8 DDCs got into the xml file, that is what the DDC found as the list of DDCs in the site.