Citrix Director Logon Performance Chart Displays “Cannot Retrieve the Data” Error Message

Citrix Director Logon Performance Chart Displays “Cannot Retrieve the Data” Error Message

book

Article ID: CTX216456

calendar_today

Updated On:

Description

In Citrix Director, the Trends > Logon Performance tab, might not display the trends chart for very large data. Typically, this error occurs when the time period is set to more than a week and the site has sessions configured on a large scale.

The table data is displayed and shows a large total number of rows. However, the chart is not presented, and the following error message is displayed: “Cannot retrieve the data.”

User-added image

The Logon Performance tab shows historical data of the Logon durations in chart and table formats. At each plotted point on the chart, a tooltip containing a detailed drill down of the Logon duration is displayed. It shows the duration of various logon phases; from the time the user connects from Citrix Receiver to the time the desktop or application is ready to use. This information helps the administrator in understanding the exact cause of delay, if any, in the logon process.

User-added image

Resolution

To resolve this problem, disable the Logon duration tooltip on the chart. This reduces the time taken for data retrieval and processing, and the chart is also displayed for very large data.
To configure web.config using IIS:

  1. Open the IIS Manager console.

  2. Go to the Director website under the Default website.

  3. Double-click Application Settings.

  4. Add the field EnableLogOnTrendTooltip, set its value to “false”.

  5. Restart IIS.

The Logon performance tooltip is enabled by default if:

  • The EnableLogOnTrendTooltip field is not configured (not present in the web.config file) or

  • The value of EnableLogOnTrendTooltip is set to “true”.

Note: This solution is applicable only for the Logon Performance chart.


Problem Cause

The Logon breakdown details displayed in the tooltip requires considerable data processing, which increases as the data grows. Typically, for data beyond 1 million rows, the data retrieval cannot be retrieved and the chart is not displayed.

Issue/Introduction

Citrix Director Logon Performance chart displays “Cannot retrieve the data” error message.