Cloud Bridge: Upgrading Virtual WAN MCN from 8.1 to 9.0

Cloud Bridge: Upgrading Virtual WAN MCN from 8.1 to 9.0

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Article ID: CTX216445

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Updated On:

Description

An error occurred while transfer software to change management system. ret =-1, file = /tmp/CB-VW-PKG-9.0.1.31.UPG

Resolution

In GUI:
  1. Navigate to Configuration > System Maintenance -> Update Software -> “Update Operating System Software”
  2. Click on “Choose File” option to provide the “CB-VW-PKG-9.0.1.31.UPG” file
  3. Click on “Upload and Upgrade”
 
After the above,
Expected behavior :
  1. This step may take about 20 minutes to complete.
  2. The UI should automatically redirect to the “Change Preparation” step of the ‘Change Management’ process.
 
Unexpected behavior :
  1. We get the below error:
 An error occurred while transfer software to change management system. ret =-1, file = /tmp/CB-VW-PKG-9.0.1.31.UPG 
  1. Troubleshooting which can be done: By the error message, the system seems to have run out of disk space.
    1. Reboot the MCN appliance and try to upgrade once more.
    2. Alternate solution is, if you get support access (user: CBVWSSH) to the MCN appliance you could login to the box and clean up /tmp and /var/tmp directories. Retry upgrade after the tmp directory clean-up.
  2. However even after performing the above several times still we got the same error.
    1. As the redirect didn’t work automatically. Thus Go directly to the Change management.
    2. Navigate to Change Preparation
    3. Upload the files related to hardware asked,
  3. Upload tar.gz files and then verify.
  4. Then complete Appliance staging.
  5. And then Activate.
Upgrade successful after this.
 

Problem Cause

By the error message, the system seems to have run out of disk space.