Windows 10 Anniversary Update (v1607) – Citrix Known Issues

Windows 10 Anniversary Update (v1607) – Citrix Known Issues

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Article ID: CTX216312

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Updated On:

Description

Microsoft releases software updates for Windows 10 periodically. In August 2016, Microsoft has released its latest update for Windows 10 called Anniversary Update (v1607). Some of the known issues of this update with Citrix XenDesktop and XenApp in conjunction with the following listed Citrix products and known workarounds for respective issues are listed below:

  • Citrix Virtual Delivery Agent (VDA) for Windows Desktop OS 7.x

  • Citrix Receiver for Windows 

Note:

  • This is a live article, and is updated as and when the new information becomes available.
  • Known issues listed below may be experienced when a Citrix VDA for Windows Desktop OS or Citrix Receiver running on Windows 10 (RTM or v1511) is updated to Windows 10 Anniversary Update (v1607).
  • Issues 1 through 4, and issue 9 are not experienced if Citrix VDA for Windows Desktop OS or Citrix Receiver is installed for the first time on a machine already running Windows 10 Anniversary Update (v1607).
  • Issues 1 through 4 are fixed by Microsoft with the latest Windows 10 Creators Update (v1703). Known issues with Creators Update are documented on CTX223074 - Windows 10 Creators Update (v1703) – Citrix Known Issues.
  • Citrix advises not to apply the Anniversary Update (v1607) on existing Windows 10 machines with Citrix VDA for Windows Desktop OS installed. Citrix recommends uninstalling the VDA for Windows Desktop, applying the Anniversary Update (v1607) and then reinstalling Citrix VDA for Windows Desktop.

Known Issues

The following are the known issues:

Issue 1

Issue Description

When Anniversary Update (v1607) is applied on a Windows 10 RTM/v1511 machine with Citrix VDA for Windows Desktop OS installed, users are unable to see mapped drives (Client Drive Mapping)

Problem Cause

While upgrading to Anniversary Update (v1607), few registry entries required by Citrix features gets removed (HKLM->System -> CurrentControlSet -> Control ->NetworkProvider)

Solution

Microsoft has resolved this issue with Windows 10 Creators Update (v1703). When a Windows 10 machine is upgraded to Creators Update, this issue is not experienced.

If you are experiencing this issue after upgrading to Windows 10 v1607:

Workaround 1

Users may manually add the registry keys that were deleted by the installer by following below steps:
Caution! Refer to the Disclaimer at the end of this article before making changes to Registry.

  1. Right click on Start button and choose Run
  2. Type regedit and click OK.
  3. Browse to HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Services.
  4. Right-click on Services and choose New > Key.
  5. Enter value PICAClientNetwork for the new key and click OK.
  6. Right Click on PICAClientNetwork, choose New > String Value, enter Group and Value data NetworkProvider
  7. After adding the keys and values, it should appear like below:

    User-added image

  8. Right-click the newly created key PICAClientNetwork and choose New > Key.
  9. Enter value NetworkProvider and click OK.
  10. Add the following four entries under the newly created key:
    1. Right-click NetworkProvider > New > String Value, enter Name and set Value data PICAClientNetwork.
    2. Right-click NetworkProvider > New > Expandable String Value, enter ProviderPath and set Value data %CommonProgramFiles%\Citrix\System32\PicaProvider.dll.
    3. Right-click NetworkProvider > New > String Value, enter DeviceName and set Value data \Device\PicaDriveRedirector.
    4. Right-click NetworkProvider > New > DWORD 32 bit, enter Class and set Value data 1.
  11. After adding the keys and values, it should appear like below:
    User-added image

  12. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order, right click on ProviderPath and choose option Modify.  Append ‘PICAClientNetwork,’ to the start of the existing value.
  13. After adding the keys and values, it should appear like below:
    User-added image

Alternately, users can download and run the registry file that adds the above entries. Download the attachment.zip file, extract it to a folder, browse through folder for issue #1 and double click on VDA_CDM.REG file. Users are advised to test the .REG file before using it in a production environment.

Note:

  • If any third party services are registered with Microsoft Network Provider under HKLM\System\CurrentControlSet\Control\NetworkProvider, and retained after upgrading to Windows 10 Anniversary Update, using this .REG file will remove it. The .REG file will overwrite the value to “ProviderOrder"="PICAClientNetwork,RDPNP,LanmanWorkstation,webclient"

Caution! Refer to the Disclaimer at the end of this article before making changes to Registry

Workaround 2

Users could run the Power Shell script that adds the above entries. Download the attachment.zip file, extract it to a folder, browse through folder for issue #1 and run the Power Shell script VDA_CDM.PS1. This script will add the registry entries and retains services registered with Microsoft Network Provider. Users are advised to test the script before using it in a production environment.

Workaround 3

Users may try to reinstall the Citrix VDA. If reinstall fails, users are recommended to use the VDA Cleanup utility and then reinstall Citrix VDA.

 

Issue 2

Issue Description

When Anniversary Update (v1607) is applied on a Windows 10 RTM/v1511 machine with Citrix Receiver installed, Pass-Through Authentication (SSON) fails.

Problem Cause

While upgrading to Anniversary Update (v1607), few registry entries required by Citrix features gets removed (HKLM > System > CurrentControlSet > Control >NetworkProvider).

Solution

Microsoft has resolved this issue with Windows 10 Creators Update (v1703). When a Windows 10 machine is upgraded to Creators Update, this issue is not experienced.

If you are experiencing this issue after upgrading to Windows 10 v1607:

Workaround 1

Users may manually add the registry keys that were deleted by the installer by following below steps:

Caution! Refer to the Disclaimer at the end of this article before making changes to Registry

  1. Right click on Start button and choose Run

  2. Type regedit and click OK.

  3. Browse to HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Services.

  4. Right-click on Services and choose New > Key.

  5. Enter value PnSson for the new key and click OK.

  6. Right-click the key PnSson for and choose New > DWORD 32 bit, enter IsEnabled and set Value data 1

  7. Right-click the key PnSson for and choose New > DWORD 32 bit, enter Type and set Value data 4

  8. After adding the keys and values, it should appear like below:
    User-added image

  9. Right-click the key PnSson and choose New > Key.
  10. Enter value NetworkProvider and click OK.
  11. Add the following entries under the newly created key:
    1. Right-click NetworkProvider > New > String Value, enter Name and set Value data Citrix Single Sign-on.

    2. Right-click NetworkProvider > New > String Value, enter ProviderPath and set Value data to below value:
      C:\Program Files (x86)\Citrix\ICA Client\x64\pnsson.dll on 64 bit Machine
      C:\Program Files\Citrix\ICA Client\pnsson.dll on 32 bit Machine
      Note: If receiver is installed in Custom location, the above values should be changed accordingly to $InstallPath$\ICA Client\... Example: If install path is c:\Citrix then the value should be C:\Citrix\ICA Client\....

    3. Right-click NetworkProvider > New > DWORD 32 bit, enter Class and set Value data 2.

  12. After adding the keys and values, it should appear like below:
    User-added image

  13. Browse to HKEY_LOCAL_MACHINE> SYSTEM> CurrentControlSet> Control> NetworkProvider> Order

  14. Right Click on ProviderOrder and Select Modify.

  15. Add ,Pnsson to the end of the current value in the registry.

  16. After adding the keys and values, it should appear like below:
    User-added image

  17. Browse to HKEY_LOCAL_MACHINE> SYSTEM> CurrentControlSet> Control> NetworkProvider> HwOrder

  18. Right Click on ProviderOrder and Select Modify.

  19. Add ,Pnsson to the end of the current value in the registry.

  20. After adding the keys and values, it should appear like below:
    User-added image

Alternately, users can download and run the registry file that adds the above entries. Download the attachment.zip file, extract it to a folder, browse through folder for issue #2 and double click on Receiver_SSON_32.REG file on 32-bit system or Receiver_SSON_64.reg on 64-bit system. Users are advised to test the .REG file before using it in a production environment.

Notes:

  • The attached registry file works if Receiver is installed in default location. If Receiver is installed in custom location edit the Registry file and make changes to the ProviderPath as mentioned above in step 11 (b) before running the registry file.
  • If any third party services are registered with Microsoft Network Provider under HKLM\System\CurrentControlSet\Control\NetworkProvider, and retained after upgrading to Windows 10 Anniversary Update, using this .REG file will remove it. The .REG file will overwrite the value to "ProviderOrder"="RDPNP,LanmanWorkstation,webclient,PnSson".

Caution! Refer to the Disclaimer at the end of this article before making changes to Registry

Workaround 2: Users could run the Power Shell script that adds the above entries. Download the attachment.zip file, extract it to a folder, browse through folder for issue #2 and run the Power Shell script Receiver_SSON.PS1. This script will add the registry entries based on the Receiver install location. It also retains services registered with Microsoft Network Provider and appends PnSson value. Users are advised to test the script before using it in a production environment.

Caution! Refer to the Disclaimer at the end of this article before making changes to Registry

Workaround 3: Users are advised to uninstall the Citrix Receiver and reinstall with SSON enabled.

 

Issue 3

Issue Description

While upgrading to Anniversary Update (v1607), one of the Citrix driver files is preventing write operations causing the update to roll back. 

Solution

Microsoft has resolved this issue with Windows 10 Creators Update (v1703). When a Windows 10 machine is upgraded to Creators Update, this issue is not experienced.

If you are experiencing this issue after upgrading to Windows 10 v1607, Citrix suggests uninstalling the Citrix VDA from Windows 10 RTM/v1511 machines before applying the Anniversary Update (v1607). Once the update is applied, install Citrix VDA for Windows Desktop OS.

 

Issue 4

Issue Description

The CDF tracing feature may fail to work after applying the Anniversary Update (v1607) on a Windows 10 RTM/v1511 machine

Problem Cause

While upgrading to Anniversary Update (v1607), few registry entries required by Citrix CDF tracing feature and few other keys related to VDA gets removed under HKLM->System -> CurrentControlSet -> Control ->Citrix. This causes some or all of the modules to be missing in CDF Control. 

Solution

Microsoft has resolved this issue with Windows 10 Creators Update (v1703). When a Windows 10 machine is upgraded to Creators Update, this issue is not experienced.

If you are experiencing this issue after upgrading to Windows 10 v1607:

Workaround 1:

Citrix Receiver: Users can download and run the registry file that adds the required entries. Download the attachment.zip file, extract it to a folder, browse through folder for issue #4 and double click on Receiver_CDF_USBTracing.REG file. Users are advised to test the .REG file before using it in a production environment.

Citrix VDA:  Users can download and run the registry file that adds the required entries for CDF Tracing features and few other keys related to VDA. Users can download and run the registry file that adds the required entries. Download the attachment.zip file, extract it to a folder browse through folder for issue #4. Based on the version of VDA, run the appropriate .REG file. Users are advised to test the .REG file before using it in a production environment.

Citrix VDA 7.9 for Windows Desktop: Double click on VDA_CDF_ 79_32.REG on 32 bit machines and VDA_CDF_ 79_64.REG on 64 bit machines.

Citrix VDA 7.11 for Windows Desktop: Double click on VDA_CDF_ 711_32.REG on 32 bit machines and VDA_CDF_ 711_64.REG on 64 bit machines.

Workaround 2:

Users are advised to uninstall the Citrix Receiver/VDA and reinstall it.

Caution! Refer to the Disclaimer at the end of this article before making changes to Registry

 As a work around, users may try to reinstall the Citrix Receiver/VDA.

 

Issue 5

Issue Description

When user tries to launch a published desktop in full screen mode using Smart card authentication through a NetScaler environment, the PIN prompt is not visible and just the progress indicator is seen. The connection times out and the launching desktop process closes.

[#LC6245]

Problem Cause

Full screen sessions hides the PIN prompt window. As part of Anniversary update, the Windows Security and UAC prompt are updated from Winform to XAML. This causes the PIN prompt window to lose focus and stay in the background.

Solution

This is a known issue with Citrix Receiver (https://docs.citrix.com/en-us/receiver/windows/current-release/about/known-issues.html). 

  • Users on Current Release of Citrix Receiver are advised to upgrade to Citrix Receiver 4.12 or its replacement that contains the fix.
  • Users on the LTSR version(version 4.9) of Receiver are advised to upgrade to Citrix Receiver 4.9.3000 or its replacement that contains the fix.

 


Issue 6

Issue Description

On some sessions launched after a two-factor authentication (Smart Card/RSA), all mouse clicks get duplicated after a Microsoft credentials dialog is displayed. A single mouse click is recognized as double-click. Right-clicks and special mouse clicks are also affected.  All mouse clicks are duplicated for the duration of the ICA session.

[#LC6127]

Problem Cause

As part of the Windows 10 Anniversary update, Microsoft changed the Windows Security and UAC prompts from simple dialogs using Windows Forms to XAML-based dialogs for a different appearance. This change is causing mouse clicks to be duplicated.

Solution

This issue has been fixed both in Windows 10 Creators Update (v1703) and Citrix Receiver.

Users on Citrix Receiver 4.5/4.6:

Users are advised to install Citrix Receiver 4.7 or its replacement OR use Windows 10 Creators Update (v1703).

Users on Citrix Receiver 4.4.x (Up to 4.4.3000):

Users are advised to install Citrix Receiver 4.4.4000 or its replacement OR use Windows 10 Creators Update (v1703).

 

Issue 7

Issue Description

On Windows 10 VDA’s published using MCS with PvD, the ‘Apps & Features’ and ‘Storage’ options under Start -> Settings -> System fails to load.

[#LC5073]
 
Solution

There is no solution. This issue is seen with Windows 10 v1507, v1511 and v1607. This issue does not affect the functionality of PvD. It occurs when users try to access the options ‘Apps & Features’ and ‘Storage’ under Start -> Settings -> System. Administrators can still manage the disks from the console.

 

Issue 8

Issue Description

A black screen with date, time, place and other details is observed on the Lock screen instead of the background image when Citrix Receiver is installed.

Problem Cause

The option ‘Animate windows when minimizing and maximizing’ under System Properties > Performance Options > Visual Effects responsible for displaying background image on Lock screen is getting disabled.

Solution

Microsoft has released a fix to address this behaviour
The fix can be downloaded from: https://support.microsoft.com/en-us/help/4022723/windows-10-update-kb4022723

Workaround(If the above fix cannot be installed immediately)

If users are using ‘Custom’ option under System Properties > Performance Options > Visual Effects, enable the setting for ‘Animate windows when minimizing and maximizing’. 

If users are using ‘Let Windows choose what’s best for my computer’ option under System Properties-> Performance Options -> Visual Effects,  disable and re-enable the setting for ‘Animate windows when minimizing and maximizing’. 

Note: In some cases, the setting for ‘Animate windows when minimizing and maximizing’ may be lost during system reboot or when user logs off.

 

Issue 9

Issue Description

Printer redirection fails when Anniversary Update (v1607) is applied to Windows 10 v1507/v1511 machine with Citrix VDA for Windows Desktop OS installed.

Problem Cause

Printer auto-creation failure. Reason: AddPrinter() failed with status 0x5. During upgrade to v1607, a new print spooler is installed and old permissions are lost.

Solution

Users could download attachment.zip and run FixCpsvcSpoolerPermission.exe which resets the permissions. Follow below steps:

  1. On the VDA, download attachment.zip and extract to any convenient folder.

  2. Open Command Prompt as Administrator

  3. Change directory to folder where attachment.zip was extracted.

  4. Change to sub directory ‘Issue 9 - PrinterRedirection’

  5. Run ‘FixCpsvcSpoolerPermission.exe’

  6. Logoff and launch the VDA

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Issue/Introduction

Microsoft releases software updates for Windows 10 periodically. In August 2016, Microsoft has released its latest update for Windows 10 called Anniversary Update (v1607).