Studio shows error: "No connection license available. To resolve, free licenses by closing sessions that are not needed or add more licenses."

Studio shows error: "No connection license available. To resolve, free licenses by closing sessions that are not needed or add more licenses."

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Article ID: CTX216257

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Updated On:

Description

1. Studio shows error: "No connection license available. To resolve free licenses by closing sessions that are not needed or add more licenses."

2. Event Viewer on the Delivery Controller server shows the following warning message:

Source: Citrix Broker Service
Event ID: 1163
No connection license available. To resolve, free licenses by closing session that are not needed, or add more licenses.

Details:
License Server Address: 'ServerHostName.domain.com'
License Server Port: '27000'
Site License Model: 'UserDevice'
Site Edition: 'ENT'
ProductID: 'XDT'
User: 'UserName'
Client ID:Session Support: 'MultiSession'

3. When trying to re-import the license file into the License Administration Console the following error is displayed:
"Missing option file for CITRIX vendor: C:\Program Files (x86)\Citrix\Licensing\MyFiles\CITRIX.opt."

Resolution

Solution 1.

If there is another Licensing Server available, you can copy the "CITRIX.opt" file from "C:\Program Files (x86)\Citrix\Licensing\MyFiles\" to the same path on the Licensing server where the error message is displayed in the License Administration Console.

Then Refresh Studio or close it and open it again.

Note: If the Licenses are displayed correctly in the License Administration Console, Studio should display the correct information for the Licensing.
If the Licenses are not displayed correctly in the License Administration Console then re-import the License file with the option "Overwrite License File on License Server" checked. 

If the issue persists then restart Licensing Service.

Solution 2.

If there is no other Licensing Server available, then you can uninstall the Citrix Licensing program and install it again. This way the files "CITRIX.opt" and "citrix_startup" will be recreated.

Then Refresh Studio or close it and open it again.

Note: Before uninstalling the Citrix Licensing program make sure to create a copy of the folder "MyFiles" located under "C:\Program Files (x86)\Citrix\Licensing\".




 

Problem Cause

"CITRIX.opt" file missing under "C:\Program Files (x86)\Citrix\Licensing\MyFiles\".