Error message: Cannot start desktop when launching a published desktop

Error message: Cannot start desktop when launching a published desktop

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Article ID: CTX216085

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Updated On:

Description

The error message: "Cannot start desktop" is displayed when launching a published desktop.
StoreFront server shows the following error message in the Event Viewer:

Source: Citrix Store Service
Event ID: 4008
Description: The Citrix servers are not licensed to launch the resource [DesktopName]. This message was reported from the XML Service at address [http://DeliveryContollerAddress].


Delivery Controller shows the following error message in the Event Viewer:

Source: Citrix Broker Service
Event ID: 1112
Description: Citrix Broker Service failed to broker a connection for user [Username] to resource [PublishedDesktopName]. The product and edition licensing configuration for the site does not allow this type of resource. Check that the correct license has been selected for this site.

Resolution

Set Licensing to the correct Product Edition on Studio under Configuration > Licensing > Edit Product Edition (Under the Actions session on the right panel).
 

Problem Cause

Wrong Product Edition setup on Studio for Licensing.
Licensing was setup to XenApp Platinum instead of XenDesktop Platinum.