Director missing logon duration under session details
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Article ID: CTX215872
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Updated On:
Description
Director not providing the Logon Duration under session details with error:
"Cannot retrieve the data. Data source unresponsive or reported an error. View Director server event logs for further information "

On Director server we get the following errors on the event viewer:
Failed to connect to the data source 'Unknown error'
Verify that the data source is available
Resolution
This behavior will go away after the average calculation time passes, usually 7 - 15 days, by itself.
Recommendation is to let the missing records flush itself on the database instead of deleting it manually since this operation might cause the corruption of the entire database.
If manually flushing the records is required, please contact Citrix technical support for further assistance
Problem Cause
Director is not able to pull the records from one day during its average calculation time (Usually 7 - 15 days) for the session details. This is usually caused by the SQL database not being available for a particular time frame.
Issue/Introduction
Director showing: "Cannot retrieve the data" under logon duration on sessions details
Additional Information
https://discussions.citrix.com/topic/379609-upm-541-breaks-wmi/
http://docs.citrix.com/en-us/xenapp-and-xendesktop/7-9/director.html#par_anchortitle_107c
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